Custom Connector Error Unsupported major.minor version nn.n

Document created by Terese_Baker Employee on Mar 25, 2015Last modified by dave_lesshafft on Mar 1, 2016
Version 2Show Document
  • View in full screen mode
This error occurs when the version of Java that was used to compile the connector does not match the version of java that your atom is currently using. For example, your custom connector is compiled using Java 7, but your atom is currently running Java 6.
To correct this issue, you can upgrade your atom to Java7 by either using the Atom Java7 upgrade, or by performing a manual upgrade to Java7.  If you do not want to upgrade the server version of Java, but only the version that the atom uses, perform the install in a separate directory from your Java Home, and point the atom to that Java version by updating the <AtomHome>\.install4j\pref_jre.cfg.
For reference, this is a link to our documentation that describes how "To Make an Atom, Molecule or Cloud Use a Different Java Version".

Also, please see the Knowledge Base Article entitled, "Where do I download the same JRE/JDK used by the Boomi Atom Cloud?" Please note, for a local atom you would use the JRE

Finally, please see the article entitled "How to Migrate Java Certificates to New Version of Java" if you decide to manually update to Java 7 and change the <AtomHome>\.install4j\pref_jre.cfg value
.
1 person found this helpful

Attachments

    Outcomes