Increase webservices jetty container default timeout

Document created by mike_c_frazier Employee on Jan 21, 2013
Version 1Show Document
  • View in full screen mode
How can I increase the default timeout used by the internal webservices jetty container?


Note:

http://stackoverflow.com/questions/12943447/restlet-server-socket-timeout

As described in the above article, the Jetty timeout could cause the ports associated with a particular client/server communication to close before the service completes its processing.  This may cause an End Of File ( or EOF ) error on the client side ( the timeout typically is set to 30s ).  Making this change to the Jetty timeout, may address this issue.  You may also choose to investigate how to improve the performance on your service, to make sure the documents are returned within 30 seconds.

     You can increase this setting through the use of the following container property (added to the atoms container.properties file in the atoms conf directory):

     com.boomi.container.sharedServer.http.maxIdleTime=(X)

     X= the time you want to increase to in milliseconds.

     You may need to restart the atom after you make the change.

6 people found this helpful

Attachments

    Outcomes