MS SQL Driver : 1.8 is not supported by this driver. Use the sqljdbc4.jar class library

Document created by ruchika_yadav Employee on Jun 2, 2017
Version 1Show Document
  • View in full screen mode

When you are using the MS SQL server with Java 1.8 we get the following error :

 

ERROR : Unable to browse: Unable to browse connection.; Caused by: Unable to open database connection. Java Runtime Environment (JRE) version 1.8 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.; Caused by: Java Runtime Environment (JRE) version 1.8 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

 

Solution : With java 1.8 we need to have the correct sqljdbc jar file .

Steps :

  1. Download the sqljdbc42.jar file from the following link: 

 

       Download Microsoft JDBC Driver 4.2 for SQL Server from Official Microsoft Download Center 

 

     Note that the versions supported for Java Runtime Environments (JRE) and the associated JDBC API versions are determined by the included JAR files as follows:

    • Sqljdbc41.jar requires a JRE of 7 and supports the JDBC 4.1 API

   • Sqljdbc42.jar requires a JRE of 8 and supports the JDBC 4.2 API

 

So make sure that you are downloading the correct jar files. 

 

2. Place the jar file under <atom_install_dir>\lib folder.

3. Make sure the jar file is not blocked by the server. To confirm that right click on the jar file -> chose properties -> and unblock it (if you see unlock button at the bottom).

4. Also, make sure that there are only 2 jar files for sql driver in the atom_install lib folder: sqlbuilder.jar( which comes with the atom install) and sqljdbc42.jar ( which you just copied ).

5. Restart the atom now.  

6.Test your connection.

 

 

1 person found this helpful

Attachments

    Outcomes