AnsweredAssumed Answered

Sage 50 / Peachtree Order Upsert not Updating

Question asked by chris_deal Employee on Aug 31, 2017

The documentation for the connector says "Sage 50 Upsert operation differs slightly from many other connectors' operations because the action is not explicitly defined. Instead, it is determined dynamically by Sage 50 based on the data contained in the request. If the request contains an ID and the ID exists, the record is updated. If the request does not contain an ID (or if the one provided does not exist), the record is added."

 

I am trying to run an update on sales orders.  There isn't a field called exactly "ID".  I've tried the Sales_Order_Number, GUID, and Transaction_Number.  None of them work.  I was hopeful with GUID since that's what I can use to run a delete, but it didn't.  I also tried querying the order and using that exact xml profile to run an update, but no go.  I just keep getting an error of "Embedded message: [-2147352567] 80020009 Invocation failed: WARNING! The reference number '123' has already been used."

 

Has anyone successfully ran a true Upsert with Sage 50 / Peachtree?  If so, please help

Outcomes