AnsweredAssumed Answered

Dynamic Process Property is not getting flushed out

Question asked by phani.kumar@enjoy.com on May 2, 2018
Latest reply on May 3, 2018 by leif_jacobsen

Hello,

Defined a DPP (Dynamic process property variable) and tried to concatenate some text (example: I am trying to add/concatenate  all Errors/Validations/Results) into that variable at different places/stages of a process. Every time when I run this process its "not initializing" the DPP, instead concatenating the value of previous run.

 

Example : 

stage 1: Defined a DPP Property DPP_Var1 in processA

stage 2: in ProcessA, after above stage1, defined a  groovy based script "data process" to assign DPP_Var1 = DPP_Var1 + " Some string"

stage 3: Notify the string to user (either using Notify or Message or email or some other way)

stage 4: Run the process.

Every thing looks normal.  DPP_Var1 contains null + Some string (--> which is good)

stage 5: Run the process one more time

Surprisingly DPP_Var1 contains null+Some string + Some string.

Note : Persist check box is not selected for above DPP_Var1

 

Question : 

Is this an expected behavior for Boomis DPP variables/properties ?

How should I get rid of old process DPP value?

Outcomes