Error on line 1: Content is not allowed in prolog

Document created by Nikita_nandakumar on Jan 8, 2014
Version 1Show Document
  • View in full screen mode
This error usually appears while trying to import an XML profile.
The file is stored in UTF-8 format with a Byte Order Mark (BOM). This means it has leading characters that you can not see in a normal text editor or browser. Those characters are the UTF-8 BOM (byte sequence EF BB BF). Edit the xml file in a robust editor like Notepad++ and encode the file in UTF-8 without the BOM. (Should be an option off the Encoding menu in Notepad++). Save the file and try the import again. It should work after making this change to the file.

The XML Profile Import Wizard does not accept the BOM. But you should still be able to process UTF-8 files that include a BOM. For example, please try these steps:

1. Make a copy of the XML file and encoding in UTF-8 without the BOM.

2. Import the XML profile using the converted XML file. Alternatively, if the XML profile is short, you can also create it from scratch.

3. Create a simple process with a disk connector and a map that uses the new XML profile. But when you run the process, read in the original unaltered XML file that is encoded in UTF-8 with the BOM.You should be able to process the file.

This extra step of removing the BOM may only be required to perform the XML Import .

Just for reference, the XML import accepts the encoding options specified here:

http://help.boomi.com/display/BOD/XML+Profile
4 people found this helpful

Attachments

    Outcomes