HTTP 401 error when posting to a web services process

Document created by Adam Arrowsmith Employee on May 29, 2015Last modified by vreddy on Mar 1, 2016
Version 2Show Document
  • View in full screen mode
When attempting to post to an integration process published as web services process, you receive an HTTP 401 error from the Atom web server.
1. Authentication has been enabled for the Atom's shared web server but the client application is not providing credentials. To verify, within AtomSphere go to Manage > Atom Management > select the Atom > Shared Web Server Settings. On the Basic tab, confirm if authentication has been enabled. If enabled, be sure to configure the client application with the appropriate credentials.

 

2. The client application is not sending the correct credentials. If authentication has been enabled for the Atom shared web server, the HTTP request header must contain a user and password using HTTP BASIC Authentication. Remember the user name is your Account ID and the password is the authentication token generated within the Atom shared web server settings, My Authentication tab.
- Make sure that username is correct ; and make sure that encoded value is based on the username:token
URL should look like :
https://connect.boomi.com/ws/simple/someAction;boomi_auth=Zm9vOmJhcgo?blah=bazz

The AuthString above is a Base64 encoded value of <username>:<token>. Creating the AuthString parameter also requires the Base64 encoding of the colon between the username and token, so encode the entire string.

3. For locally hosted Atoms, another service is listening on the same port as the Atom web server. Note this could be another Atom if you have installed two local Atoms on the same server. Review the ports configured for the Atom in Shared Web Server Settings within Atom Management then use an appropriate tool for your runtime environment to determine what services are using which ports. For example, in Windows, open a command prompt and use the command netstat -anop TCP.

Attachments

    Outcomes