Molecule set up for Multicast by default is not clustering/communicating with other molecule nodes - Problem: MULTIPLE_HEAD_NODES

Document created by mike_aronson Employee on Jul 4, 2015Last modified by vreddy on Mar 1, 2016
Version 2Show Document
  • View in full screen mode

A molecule set up for multicast by default is not clustering/communicating with other molecule nodes.

Monitoring the node view files at the following link shows that there is a
Problem: MULTIPLE_HEAD_NODES

 

http://help.boomi.com/atomsphere/GUID-798888B5-3B15-44A9-8700-FD7737A2461F.html

By default, the Molecule node or Cloud Molecule will use the multicast address and port as described at this link:

http://help.boomi.com/atomsphere/GUID-A1A4FB0D-2A88-414D-B61D-4F6A362EFAE0.html

Steps to verify:

  1. Verify that the molecule nodes are on the same network.

  2. Confirm the nodes are able to connect to one another on the specified port. This can commonly be verified using a simple telnet command. If the nodes cannot communicate with one another, confirm there are no server firewall, network firewall, or router/switch rules that are blocking the necessary protocol and port. Default ports are:

    1. MULTICAST: Protocol=UDP, Port=45588

    2. UNICAST: Protocol=TCP, Port=7800

  3. Try capturing a network trace using a tool such as Wireshark on the nodes to see if they are receiving/sending UDP traffic. The Wireshark traces should confirm whether or not the nodes are sending UDP traffic back and forth to each other.

  4. If the multicast configuration is not working and you are unable to enable it, another option is to change the configuration to use unicast as described at this link: http://help.boomi.com/atomsphere/GUID-A95D3872-4275-488F-ACD7-51DBAF49C0C2.html

Attachments

    Outcomes