WSDL is not Accessbile from URL

Document created by paul_pasko Employee on Aug 23, 2012
Version 1Show Document
  • View in full screen mode
     A request to a published web service using a secure URL fails to return the expected WSDL.
     For this solution we have an example URL:
     where demo.example.com is the external host and 22001 is the port number
      
     Ensure that the external host is accessible through any firewalls and that the port is also open (you may need to check with your web server administrator).  Ensure that the web server is not redirecting the request.
      
     If the atom is returning an http:// URL in the schema location instead of an https:// URL, you can do the following to enforce https:
      
     1. Go to Atom Management:
     2. Select the Atom on the left and under Atom Properties, select Shared Web Server Settings.
     3. In Shared Web Server Settings, select the Advanced tab
     4. Using the example above, enter the following in these fields:
      
     Check the box next to Override Base URL and enter https://demo.example.com:22001
     External host: demo.example.com
     External port: 0
     External SSL Port: 22001
      
     5. Select OK.
      
     To verify that the settings were saved correctly, in the My Authentication tab the Base URL should now be:

Attachments

    Outcomes