How to increase the webserver idle connection timeout setting in a private atom/cloud/molecule.

Document created by vreddy Employee on Dec 3, 2013Last modified by frank_wetzler970218 on May 8, 2018
Version 5Show Document
  • View in full screen mode
When deploying web services to your atom/cloud/molecule in certain use cases where the atom webserver takes more than 30 seconds to respond to a inbound request the HTTP connection to the webserver may remain idle. This idle HTTP connection may be terminated by the webserver because of the default 30 sec idle timeout setting. Increasing the idle timeout setting may help prevent this.
 
Note: The idle timeout only applicable when there is no data being transferred and when your private atom/cloud/molecule is hosting the service not when hitting a external website. In addition the timeout cannot be modified for Boomi hosted clouds.
If a large file is being transferred and the transfer takes more than 30 seconds the connection is not considered to be idle and hence will not be terminated because of this setting.
By default the Atom web server has an idle connection timeout of 30 seconds. It can be changed by setting the "com.boomi.container.sharedServer.http.maxIdleTime" property in container properties file. This value is configured in milliseconds.

 

For example, to set the timeout to 60 seconds:

1. Edit the ../<Atom Installation Directory>/conf/container.properties file and add the line:

com.boomi.container.sharedServer.http.maxIdleTime=60000

 

2. Restart the Atom.
3 people found this helpful

Attachments

    Outcomes