How to troubleshoot Zuora query issues

Document created by mike_aronson Employee on Mar 13, 2015Last modified by dave_lesshafft on Mar 1, 2016
Version 2Show Document
  • View in full screen mode
You have a Zuora connection and it is not allowing you to import the object that is needed or
you have a Zuora query and it is returning a malformed query. It may work in one Zuora environment (e.g. sandbox)
but not in another (e.g. production).  Or it may work in one Zuora account version (e.g. 39) but not in another (e.g. 59).
Hi Long,

 

As described at this link below, the Zuora API and WSDL are assigned a new version number when objects, calls, fields, or behaviors are changed. The WSDL used in a Zuora production environment may not match the one in the Zuora sandbox environment. Many customers have different features enabled in the API Sandbox environment than in Production. And some users do not have permissions to see objects that other users can see.

 

When you try to import your Zuora Connector Operation using your Zuora Production Connection a different version, it may be missing the desired object.  Here are some steps to investigate this further.

 

1. Follow the steps in this link to check the wsdl version, download wsdl version # using your Zuora credentials to see if the object shows up in the wsdl:

 

https://knowledgecenter.zuora.com/BC_Developers/SOAP_API/AB_Getting_started_with_the__SOAP_API/B_Zuora_WSDL

 

2. Check with your Zuora administrator to confirm that the desired object is available via the API for your account version and specific user.

 

3. See if the ZOQL can be run outside of Boomi.  Zuora has a SOAP API that may help with this.  Please try running your query in the SOAP API using the account version and user.  This is described at this link:

 

https://knowledgecenter.zuora.com/BC_Developers/SOAP_API/AB_Getting_started_with_the__SOAP_API

 

Thanks,
Mike
1 person found this helpful

Attachments

    Outcomes