Error: QuickBooks Error - 80040408 (Unknown error) : Could not start QuickBooks

Document created by chris_stevens Employee on Apr 5, 2016Last modified by chris_stevens Employee on Apr 25, 2016
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Error

You receive the following error when attempting to connect to QuickBooks Desktop:

com.boomi.connector.ConnectorException: Error Executing Quickbooks Get

...

Caused by: com4j.ExecutionException: com4j.ComException: 80040408 (Unknown error) : Could not start QuickBooks. : .\invoke.cpp:447

at com4j.ComThread.execute(ComThread.java:189)

at com4j.Task.execute(Task.java:32)

at com4j.Wrapper$InvocationThunk.invoke(Wrapper.java: 242)

at com4j.Wrapper.invoke(Wrapper.java:118)

at $Proxy37.beginSession(Unknown Source)

at com.boomi.connector.quickbooks.QBGet.handleQBDE(QB Get.java:578)

at com.boomi.connector.quickbooks.QBGet.get(QBGet.jav a:98)

... 23 more

 

Cause

This is most commonly caused by not specifying the correct QuickBooks company file location in the Connection component. If you do not specify the location, the Atom will try to connect to the currently open QuickBooks session, and if none is found this error is thrown.

 

Solution

View the QuickBooks Connection setup and verify the My QuickBooks Company field has a valid value for the path to the company file.

 

If problem persists:

  • Restart QuickBooks and try again.

 

If problem persists:

  • Backup your company file.
  • Close QuickBooks.
  • Navigate to the QuickBooks installation directory. This is typically C:\Program Files\Intuit\<QuickBooks version>.
  • Run the reboot.bat file.
  • Restart the machine.
  • Remove the Boomi application from the list of Integrated Applications (within QuickBooks, Edit >> Preferences >> Integrated Applications >> Company Preferences).
  • Execute the process and re-authorize the Boomi application.

 

If the problem continues to persist

Locate the QuickBooks SDK log file on the machine, most likely located at C:\Program Data\Intuit\QuickBooks\qbsdklog.txt and see if there are additional detailed error messages regarding the issue as well.  For some errors that are QuickBooks specific, you may need to contact Intuit / QuickBooks technical support.

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