Browser "Script May Be Busy" Error

Document created by chris_fagan Employee on Jul 15, 2016Last modified by chris_stevens on Aug 10, 2016
Version 3Show Document
  • View in full screen mode

While trying to load different sections of the Boomi AtomSphere, the browser returns a script error after some time:

 

scripterror1.png

 

Issue

This issue was discovered while using Mozilla Firefox and can be a result of the Firefox script timeout being set too low while the Platform tries to load a large amount of processes. For example, while selecting the "Deploy" tab within AtomSphere, the platform attempts to load every process on the account in order to allow users to select the processes they wish to deploy. A script handles this load and depending on the amount of processes contained in the account, it can take a bit of time to load everything. If the script takes longer than the script timeout set on the browser, the error will be thrown.

 

Solution

The solution in this case would be to increase the script timeout on the browser.

 

Mozilla Firefox:

  1. In the address bar, type about:config and press Enter.
  2. A warning page may appear. Click to continue.
  3. In the about:config page, search for the preference "dom.max_script_run_time" and double click on it to modify the setting.
  4. By default, Firefox sets this value to 10. Increase it to a more appropriate value (for example, 20) and then increase as needed.
  5. Press OK and restart the browser.

1 person found this helpful

Attachments

    Outcomes