weblogic.socket.MaxMessageSizeExceededException: Incoming message of size: '10000080' bytes exceeds the configured maximum of: '10000000' bytes for protocol: 't3'

Document created by john_yocum067395 Employee on Nov 17, 2017Last modified by john_yocum067395 Employee on Nov 17, 2017
Version 2Show Document
  • View in full screen mode

Issue

When trying to consume a large message from a WebLogic message queue, you may run into the above error message.

 

Cause

If the aggregate size of the messages pushed to a consumer is larger than the current protocol's maximum message size , the message delivery fails.

 

Solution

To set the maximum message size on a WebLogic client (in this case, the Boomi Atom), add the following command line property to the atom.vmoptions file:

-Dweblogic.MaxMessageSize=300000000 (this size would be based on your expected maximum message size)

 

A restart of the atom will be required for the new setting to take affect.

 

Attachments

    Outcomes