Proxy authentication issue with Java 8 update 111

Document created by denis.bredelet@dell.com on Jun 1, 2018Last modified by thanh_n88 on Jun 1, 2018
Version 2Show Document
  • View in full screen mode

Symptoms

When using a proxy on an Atom running on Java 8 update 111 or later, the atom fails to authenticate with the proxy and this warning appears in the container log:

May 29, 2018 7:50:50 PM PST WARNING [com.boomi.container.core.StatusReporter runImpl] Error sending StatusUpdate. 
java.io.IOException: Failed sending status update: Communication Error (1001) Unable to complete the HTTP call due to a communication error with the remote server. Unable to tunnel through proxy. Proxy returns "HTTP/1.1 407 Proxy Authentication Required"

This causes connection failures and the atom appears offline in the platform.

 

Note: Java 8 update 111 is not supported by Boomi. We have done extensive testing on Java 8 update 66. 

 

Solution

Add the following to atom.vmoptions (located in <atom_installation_directory>/bin):

-Djdk.http.auth.tunneling.disabledSchemes=""

Attachments

    Outcomes