AnsweredAssumed Answered

Adjust time-out for web service response

Question asked by dimitri.van.heumen@ngahr.com on Apr 4, 2016
Latest reply on Apr 6, 2016 by dimitri.van.heumen@ngahr.com


One of my sub-processes requires a very long (+/- 30 minutes) before I receive its response. It generates a large file, so it'll always take this long.

From my understanding one cannot change the time-out setting on a per sub-process basis.

I did find that you can change network time-out settings when using a local atom.

You can adjust the value for -Dsun.net.client.defaultReadTimeout in the atomw.vmoptions file. After having changed the value (to 2400000 ms), I tried running the sub-process, when an error occured:

java.io.FileNotFoundException: \C:\Program Files (x86)\Java\jre1.8.0_65\lib\ext\sunmscapi.jar; Caused by: \C:\Program Files (x86)\Java\jre1.8.0_65\lib\ext\sunmscapi.jar

 

I decided to edit the JAVA_HOME and PATH env. variables on the machine that runs the local atom. This version does have the sunmscapi.jar in the /lib/ext directory.

Now I still receive an error:

Test execution of ASR: HR Payslip Processing completed with errors. Embedded message: Could not initialize class sun.security.mscapi.SunMSCAPI

 

 

So, my question is twofold: Is there no other way to extend  time-out settings (for a specific process) using a cloud atom?

And if the answer is no for the above question, how can the sumscapi.ja error be resolved?

 

Thanks!

Outcomes