AnsweredAssumed Answered

CSV file to DB table: only 1st record goes through

Question asked by m.schmidt on Jun 20, 2017
Latest reply on Jun 21, 2017 by m.schmidt

Hi guys, I'm new to Boomi, so may be missing a simple concept here. Please help.

 

Use Case: Read a .csv file and insert the records into an SQL database table.

Problem: Only the first record is coming through to the database upon the successful process test.

Assumption: I assume that Boomi will loop through each record in the .csv file and insert it into the database without me having to implement the looping.

Test result: Success.

 

 

Setup:

The process is very simple: flat file connector in the start shape with a get operation; map; DB connector with a send operation.

 

The flat file connector is also simplistic, default options, no caching, contains only 2 records for simplicity, valid data.

 

The DB connector operation is basic too.

 

Could not make the map any simpler either:

 

 

The flat file profile has 'using column headers' checked.

The DB profile is using a dynamic insert into a single table.

 

Debugging:

'Shape Source Data' at Map stage (as expected):

 

 

'Shape Source Data' at the next step after Map (not sure if that looks right):

 

 

Log at the DB connector (successfully writing the 1st record):

 

 

Everything else looks normal too.

What am I doing wrong?

Thanks in advance.

 

Cheers,

Maria

Outcomes