AnsweredAssumed Answered

Shared Server Max Idle Timeout Not Working Anymore?

Question asked by minh.nguyen700721 on Jul 10, 2017
Latest reply on Dec 4, 2017 by josh_hutchins778263

Hello,

 

I had previously followed the steps in the following document, Increase webservices jetty container default timeout , to increase the default timeout from 30 seconds to 120 seconds by adding 'com.boomi.container.sharedServer.http.maxIdleTime=120000' to the ~/conf/container.properties file. This had fixed the problem before. But now suddenly, this property change doesn't seem to be working anymore. I tried a test similar to that specified in Are there any settings available related to web server regarding file size or time? where I created a simple web service operation that just does a sleep command, and I had the same findings. With large inputs (I used 6.8mb) the service call still timed out at 30 seconds, but with smaller inputs (I tried < 200 kb) the service call did not timeout and completed successfully.

 

I was wondering if there has been any regression with an Atom update, or if anyone else has found the same problem arise?

 

Regards,

Minh Nguyen

Outcomes