AnsweredAssumed Answered

listener not showing up in atom

Question asked by thinkpanther on Oct 11, 2017
Latest reply on Oct 12, 2017 by thinkpanther

Dear All,

 

I a newbie to Boomi and am trying to create my first API project. What I have done is the following-

 

Create a new API called Travel Agency API as per screenshots attached

Configured the Travel Service process to have a web service connector with listener for the get:/flights operation

Right now I only want this process to return a preset json response which I set in Message component and then stop the process

I have deployed the process and the api in a test atom which is attached to an environment and am trying to invoke api/process using postman

however, most of the times I get unauthorised error while at other times I get :

 

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
<title>Error 404 No such path</title>
</head>
<body>
<h2>HTTP ERROR 404</h2>
<p>Problem accessing /ws/simple/getFlights. Reason:

<pre> No such path</pre>
</p>
</body>
</html>

 

In the above message the path is the simple path that shows up in the ws operation details (see attachment screenshot)

 

I have tried changing the API type to Advanced from Intermediate; even changed the Authentication type to None from Basic but it makes no difference

 

When I give the actual path of the API: /ws/rest/v1/agency/flights/

sometimes I get 401, sometimes 404 as above and sometimes the postman connection continues waiting indefinitely...see attachment

 

I tried looking into the Listeners tab in the atom but nothing shows up(see attachment)

 

I downloaded the web service logs but even they dont have much info (see attachment)

 

Can someone advise how should I debug this issue?

 

Thanks

Outcomes