AnsweredAssumed Answered

Connecting Boomi to Rabbit MQ via a JMS Client

Question asked by bhargavi.chandrasekar848518 on Oct 25, 2017
Latest reply on Sep 5, 2018 by steven.hooper397137

Hi,

 

I'm doing a POC and I have a requirement that needs Boomi to connect to RabbitMQ. Initially, I tried to modify the steps outlined in this article: https://community.boomi.com/docs/DOC-2622 (it explains how to connect Boomi to Microsoft's Azure Service Bus), to suit my case, however I faced an un-related authentication issue (which has been raised by others here: https://community.boomi.com/message/18024?commentID=18024, so I'm not going to bring that up again). Since then I've been trying to get the JMS connector to talk to RabbitMQ via RabbitMQ's JMS client library instead.

 

These are the steps I followed to get that up and running:
1. Put the following 3 jars in the directory <boomi-local-atom-root>/userlib/jms -
       a. amqp-client-4.1.1.jar
       b. fscontext-4.5-b25.jar
       c. rabbitmq-client.jar
2. Restarted the atom.
3. Created a .bindings file for the jndi/amqp information needed in the directory: <boomi-local-atom-root>/jndi/ (I've attached that here as 'bindings.txt').
4. Created a sample process to pull files from my local directory and push it to a JMS connector. This flow has just three components, a Disk connector to get the files, a JMS connector to send the files and a stop component.
5. Configured my JMS connection as shown in jmsConnection.PNG.
6. Configured my JMS operation as shown in jmsOperation.PNG.
7. Saved and ran the process.

 

However, I got the following issue:
com.boomi.connector.ConnectorException: Unable to send JMS message; Caused by: javax.naming.NameNotFoundException: MyConnectionFactory

 

I thought it was probably because the provider url mentioned only a filepath - not the file itself. So I tried changing the url to: file:<boomi-local-atom-root>/jndi/.bindings and ran it again. This time I got this error:
com.boomi.connector.ConnectorException: Unable to send JMS message; Caused by: Unable to create initial context; Caused by: javax.naming.NotContextException; remaining name '<boomi-local-atom-root>\jndi\.bindings'

 

It seems the connector is unable to recognize the bindings file and therefore the content in it. Have I missed a step? Is there anyway I can make this entire concept work? If not, if anyone has any suggestions about how to connect Boomi to RabbitMQ I'd really appreciate it.

 

Thanks,
Bhargavi

Attachments

Outcomes